(2) Apache的日志文件
EU#^7 Apache的日志文件是非常重要的,可以发现apache的运行状况和访问情况,对于判断入侵等有重要帮助。它的默认选项是:
>$7B
wO # 错误日志存放目录,默认是存放在apache安装目录的logs下
4qa.1j(R/ ErrorLog logs/error_log
l]SX@zTb # 日志记录的级别,级别有debug, info, notice, warn, error, crit等,默认是“warn”级别
v$9y,^p@e
LogLevel warn
zQ PQ # 访问日志记录的格式,每一种格式都有不同的内容,根据你的需要进行定制,以获取最多访问信息
=_^X3z0 LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined
:4|4 =mkr LogFormat "%h %l %u %t \"%r\" %>s %b" common
j>kqz>3 LogFormat "%{Referer}i -> %U" referer
!VpoZ LogFormat "%{User-agent}i" agent
Hn:Crl y# # 使用上面格式的那一种,默认是使用common
q3`u1S7Z7 CustomLog logs/access_log common
dh\P4 O6Y0XL 文件格式预定义的格式内容:
rC5O")I< %a 远程用户IP
HaYo!.(Fv %A 本地httpd服务器的ip
gqR(.Pu %f 传送的文件名
rN>R|]. %h 远程主机
wIgS3K %m 请求方式
}m8q}~>tL %l identd给出的远程名
y{Q
{'De %p 连接的httpd端口号
d(K+);! %P 请求的httpd进程
=~gvZV-< %t 时间
dN6?c'iN?2 %T 服务请求时间
/wv0i3_e
你可以定制自己的日志格式,然后通过CustomLog logs/access_log common来进行调用。
lquLT6] naNghGQ 注意,日志文件是由运行Apache的用户进行打开的,要注意该文件的安全,防止被黑客改写或者删除。
EM_d8o)`B E-FUlOG& (3) Apache服务信息显示控制
#9s,#
} 在配置文件中有个选项是控制是否显示apache版本信息、主机名称、端口、支持的cgi等信息的:
k3|Z7eW}[ ServerSignature On
?]5qr?W% 默认为On,那么将显示所有信息:
_0I@xQj- 我故意访问一个不存在的文件:
http://www.target.com/404.html \<K5ZIWV 那么就会在给的错误提示中显示如下信息:
EX"yxZ~ Apache/2.0.53 (Unix) PHP/4.3.11 Server at target.com Port 80
9H~n_ 3' 'me 所有Apache和PHP的信息暴露无遗,这是很不安全的。当然同时还有Off和EMail选项,Off将不显示任何信息,EMail将显示管理员的邮箱地址,建议设为Off或者EMail,这样能够避免泄漏Apache服务器的信息给黑客。
jWgX_//! ~M$Wd2Th (4) 目录浏览
iDD$pd,e\ 在httpd.conf中可以设置apache能够对一些没有索引文件的网页目录进行目录浏览:
|BYRe1l6l QWU-m{@~& Options Indexes FollowSymLinks
'fW-Y!k% AllowOverride None
xx $cnG @+DX.9 这是不合适也不安全的,建议不需要目录浏览:
l"]V6!-U &j6erwaT Options FollowSymLinks
NlXimq AllowOverride None
"jCu6Rj d r<\u6jF @]0%L0u (5) 用户主页
.]Z"C&"N] 设置httpd.conf中的:
DNi+"[~&P UserDir public_html
[Qr"cR^ 能够使得每个使用系统的用户在自己的主目录下建立 public_html 目录后就能够把自己的网页放进该目录,然后通过:
DwF hK* http://www.target.com/~用户名/网页 就能够显示自己的网页,这是不安全的,而且对于我们服务器来讲,这没有必要,所以我们直接关闭该功能:
P~dcW UserDir disabled
]'S^] 或者把该内容改名,改成 一个黑客比较不容易猜到的文件名,比如:
92{\B-
l UserDir webserver_public_htmlpath
-qoH,4w 也可以只允许部分用户具有该功能:
(sj,[
UserDir enabled user1 user2 user3
LQ% `c (.,G=\! (6) CGI执行目录
,?3G;- 如果你的apache要执行一些perl等cgi程序,那么就要设置一下选项:
%)n=x
ne ScriptAlias /cgi-bin/ "/usr/local/apache/cgi-bin/"
Pz^544\~ou 但是这也给了黑客利用一些不安全的cgi程序来进行破坏,所以如果你不需要cgi的话,建议关闭该选项:
%)wjR/o #ScriptAlias /cgi-bin/ "/usr/local/apache/cgi-bin/"
Pc9H0\+Xk ]f3>-)$* (7) 控制PHP脚本只能访问指定目录
n`KY9[0U= 在httpd.conf添加如下内容:
SAz php_admin_value open_basedir /usr/www
hOeRd#AQK 后面的路径是你需要PHP脚本能够访问的目录,如果PHP脚本想要访问其他目录将出项错误提示。
H.0K?N&\?> =lC7gS!U (8) 目录访问控制 (未完)
Dzbz)Zst 这项内容最复杂,同时涉及的东西也比较多,我只能简单说一下,不清楚请参考其他文章。
_-\#i 比如下面的内容:
@WB@]-+J
T ;Qq\DFe.w Options FollowSymLinks
saAF+H/= AllowOverride None
|g~ZfnP_% `x|?&Ytmf9 就是允许访问每一个目录,里面设置的是允许执行的动作,一般包含的动作有:Options、AllowOverride、Order、Allow、Deny。
O@P"MXEG Options是只对指定目录及其子目录能够执行的操作,Indexes、Includes、FollowSymLinks、ExecCGI、MultiViews、None、All等操作。
;\]@K6m/Ap AllowOverride是指定目录访问的权限,当然也可以通过 AccessFileName文件指定的 .htaccess 来控制。它的操作有:None、All、Options、FileInfo、AuthConfit、Limit等。
n*$ g]G$ Order、Allow、Deny三个指令必须配合来控制目录访问权限。Order指定检查次序的规则,比如Order Allow, Deny,表示先按Allow检查,如果不匹配再按Deny进行检查。Order Deny, Allow ,表示先按Deny规则检查,如果不满足条件,再按Allow进行检查。
=T_g}pu h$*!8=M 控制目录访问权限的文件
w(rE`IgW 默认在Unix平台下能够使用 .htaccess 来对目录权限进行规则定义,但是这是不安全的,建议关闭,默认的选项:
u&NV,6Fj2[ AccessFileName .htaccess
*](iS 建议设成:
7Ix973^ #AccessFileName .htaccess
~m |BC*) 全部目录权限定义使用httpd.conf中的定义,不使用 .htaccess。
nrb Ok4Dz M_8{]uo (9) 用户访问认证
rGO8!X 3d 这个技术非常重要,能够控制一些非法用户访问本内容。假设我们的网站:
http://www.target.com/admin 是我们的后台管理目录,我不允许一些非法用户进行访问,那么我就必须设定对该目录访问是需要验证的。
:-'qC8C 先在httpd.conf中加入要进行访问认证的目录:
]{iQ21`a- $C\BcKlmv authtype basic
:%.D78& authname "Private"
HV.t6@\}; authuserfile /usr/local/apache/bin/admin.dat
O84i;S+-p require user login_user
#F#%`Rv1 Options Indexes FollowSymlinks MultiViews
nK,w]{<wG! AllowOverride None
hQi2U KSvE~h[#+ 上面我们就设置了我们的 /usr/www/admin目录是必须进行认证才能访问的,接着我们设置访问密码:
ys~x$ # /usr/local/apahche/bin/htpasswd -c /usr/local/apache/bin/admin.dat login_name
7Wno':w8 New password: *****
pUTr!fR Re-type new password: *****
putrSSL} Adding password for user login_name
?EL zj ,)XLq8 那么下次任何用户访问
http://www.target.com/admin目录的时候就需要输入用户名login_name和你设置的密码。
_LPHPj^Pg w@b)g (?c-iKGc 2. PHP安全设置
OH88n69 Z7#+pPt! PHP本身再老版本有一些问题,比如在 php4.3.10和php5.0.3以前有一些比较严重的bug,所以推荐使用新版。另外,目前闹的轰轰烈烈的SQL Injection也是在PHP上有很多利用方式,所以要保证安全,PHP代码编写是一方面,PHP的配置更是非常关键。
N0lC0
N?_J 我们php手手工安装的,php的默认配置文件在 /usr/local/apache2/conf/php.ini,我们最主要就是要配置php.ini中的内容,让我们执行php能够更安全。
eJSxn1GW 整个PHP中的安全设置主要是为了防止phpshell和SQL Injection的攻击,一下我们慢慢探讨。我们先使用任何编辑工具打开/etc/local/apache2/conf/php.ini,如果你是采用其他方式安装,配置文件可能不在该目录。
,^:.dFH6 [~^0gAlQC (1) 打开php的安全模式
<!+Az,- php的安全模式是个非常重要的内嵌的安全机制,能够控制一些php中的函数,比如system(),同时把很多文件操作函数进行了权限控制,也不允许对某些关键文件的文件,比如/etc/passwd,但是默认的php.ini是没有打开安全模式的,我们把它打开:
T|p"0b A safe_mode = on
yLGRi^d# N$DkX)Z (2) 用户组安全
*Uh!>Iv; 当safe_mode打开时,safe_mode_gid被关闭,那么php脚本能够对文件进行访问,而且相同组的用户也能够对文件进行访问。
RpK@?[4s 建议设置为:
sRW<me; safe_mode_gid = off
K8~d^G 如果不进行设置,可能我们无法对我们服务器网站目录下的文件进行操作了,比如我们需要对文件进行操作的时候。
+:f"Y0 _+,TT['57s (3) 安全模式下执行程序主目录
gSgr6TH0 如果安全模式打开了,但是却是要执行某些程序的时候,可以指定要执行程序的主目录:
Gq6*SaTk safe_mode_exec_dir = /usr/bin
<UI
[%yXj 一般情况下是不需要执行什么程序的,所以推荐不要执行系统程序目录,可以指向一个目录,然后把需要执行的程序拷贝过去,比如:
<[phnU^
8 safe_mode_exec_dir = /tmp/cmd
s S
Mh`4' 但是,我更推荐不要执行任何程序,那么就可以指向我们网页目录:
(ZGbhMK safe_mode_exec_dir = /usr/www
<Uur^uB :+Z%; Dc (4) 安全模式下包含文件
=I4lL]> 如果要在安全模式下包含某些公共文件,那么就修改一下选项:
>Q/Dk7 # safe_mode_include_dir = /usr/www/include/
VQs5"K" 其实一般php脚本中包含文件都是在程序自己已经写好了,这个可以根据具体需要设置。
C}X\|J n?Q|)2 2 (5) 控制php脚本能访问的目录
.N3mb6#[R 使用open_basedir选项能够控制PHP脚本只能访问指定的目录,这样能够避免PHP脚本访问/etc/passwd等文件,一定程度上限制了phpshell的危害,我们一般可以设置为只能访问网站目录:
@,}UWU open_basedir = /usr/www
DqPw#<"H !<oe=)Iz| (6) 关闭危险函数
TseGXYH 如果打开了安全模式,那么函数禁止是可以不需要的,但是我们为了安全还是考虑进去。比如,我们觉得不希望执行包括system()等在那的能够执行命令的php函数,或者能够查看php信息的phpinfo()等函数,那么我们就可以禁止它们:
~@!bsLSMU disable_functions = system,passthru,exec,shell_exec,popen,phpinfo
*#2h/Q. 如果你要禁止任何文件和目录的操作,那么可以关闭很多文件操作
j+!v}*I![ disable_functions = chdir,chroot,dir,getcwd,opendir,readdir,scandir,fopen,unlink,delete,copy,mkdir,rmdir,rename,file,file_get_contents,fputs,fwrite,chgrp,chmod,chown
9ati`-y2 以上只是列了部分不叫常用的文件处理函数,你也可以把上面执行命令函数和这个函数结合,就能够抵制大部分的phpshell了。
@ 7u 0v [m -bV$-d (7) 关闭PHP版本信息在http头中的泄漏
\G BuWY3B 我们为了防止黑客获取服务器中php版本的信息,可以关闭该信息斜路在http头中:
[RL9>n8f expose_php = Off
>sF)BoLc 比如黑客在 telnet
www.target.com 80 的时候,那么将无法看到PHP的信息。
4
:v=pZ edD)TpmE, (8) 关闭注册全局变量
5N]"~w* 在PHP中提交的变量,包括使用POST或者GET提交的变量,都将自动注册为全局变量,能够直接访问,这是对服务器非常不安全的,所以我们不能让它注册为全局变量,就把注册全局变量选项关闭:
jylD6IT register_globals = Off
[?gP; , 当然,如果这样设置了,那么获取对应变量的时候就要采用合理方式,比如获取GET提交的变量var,那么就要用$_GET['var']来进行获取,这个php程序员要注意。
RNL9>7xV "|NI]Kv (9) 打开magic_quotes_gpc来防止SQL注入
wq{hF< SQL注入是非常危险的问题,小则网站后台被入侵,重则整个服务器沦陷,所以一定要小心。php.ini中有一个设置:
;|RTx magic_quotes_gpc = Off
Q/?$x*\> 这个默认是关闭的,如果它打开后将自动把用户提交对sql的查询进行转换,比如把 ' 转为 \'等,这对防止sql注射有重大作用。所以我们推荐设置为:
-/4P3SG/ magic_quotes_gpc = On
Kq!3wb; }b}m3i1 (10) 错误信息控制
jCY%| 一般php在没有连接到数据库或者其他情况下会有提示错误,一般错误信息中会包含php脚本当前的路径信息或者查询的SQL语句等信息,这类信息提供给黑客后,是不安全的,所以一般服务器建议禁止错误提示:
:]"V-1#} display_errors = Off
gIfh3 D=yX 如果你却是是要显示错误信息,一定要设置显示错误的级别,比如只显示警告以上的信息:
uO**E-` error_reporting = E_WARNING & E_ERROR
DH=hH&[e(d 当然,我还是建议关闭错误提示。
7^285)UQA NHt\
U9l' (11) 错误日志
rjP/l6
~' 建议在关闭display_errors后能够把错误信息记录下来,便于查找服务器运行的原因:
0_/[k*Re log_errors = On
y}
'@R$ 同时也要设置错误日志存放的目录,建议根apache的日志存在一起:
2!\DPX error_log = /usr/local/apache2/logs/php_error.log
JC"z&ka 注意:给文件必须允许apache用户的和组具有写的权限
eE Kf|I 3. Mysql的安全设置
K:M8h{Ua =D(j)<9$A 我们把Mysql安装在 /usr/local/mysql目录下,我们必须建立一个用户名为mysql,组为mysql的用户来运行我们的mysql,同时我们把它的配置文件拷贝到 /etc目录下:
m~|40) # cp suport-files/my-medium.cnf /etc/my.cnf
;"I^ZFYX chown root:sys /etc/my.cnf
cNrg#Asen& chmod 644 /etc/my.cnf
/QQ*8o8 Q59suL 使用用户mysql来启动我们的mysql:
?0.NIu,,o # /usr/local/mysql/bin/mysqld_safe -user=mysql &
+ 3gp%`c4 }vuARZ> (1) 修改root用户的的口令
K"6vXv4QO 缺省安装的mysql是没有密码的,所以我们要修改,以防万一。下面采用三种方式来修改root的口令。
iscz}E,Y #Z #-Ht * 用mysqladmin命令来改root用户口令
X2_=agEP # mysqladmin -uroot password test
}ZI7J 这样,MySQL数据库root用户的口令就被改成test了。(test只是举例,我们实际使用的口令一定不能使用这种易猜的弱口令)
V9vTsmo( Iv *<La * 用set password修改口令:
im8 CmQ mysql> set password for root@localhost=password('test');
B~mj 8l4 这时root用户的口令就被改成test了。
:s,Z<^5a)g ~u{uZ(~ * 直接修改user表的root用户口令
SM'|+ d mysql> use mysql;
0K+ne0I mysql> update user set password=password('test') where user='root';
1 zZlC#V mysql> flush privileges;
]5O~+Nf =]t|];c% 这样,MySQL数据库root用户的口令也被改成test了。其中最后一句命令flush privileges的意思是强制刷新内存授权表,否则用的还是缓冲中的口令,这时非法用户还可以用root用户及空口令登陆,直到重启MySQL服务器。
0b>h$OU/ Xvv6~ (2) 删除默认的数据库和用户
=l6mL+C 我们的数据库是在本地,并且也只需要本地的php脚本对mysql进行读取,所以很多用户不需要。mysql初始化后会自动生成空用户和test库,这会对数据库构成威胁,我们全部删除。
#E?4E1bnB 我们使用mysql客户端程序连接到本地的mysql服务器后出现如下提示:
J,hCvm mysql> drop database test;
mw!F{pw mysql> use mysql;
'91/md5 mysql> delete from db;
29rX%09T] mysql> delete from user where not(host="localhost" and user="root");
_$'ashF mysql> flush privileges;
/z!%d%" }C:r9?T (3) 改变默认mysql管理员的名称
\zY!qpX< 这个工作是可以选择的,根据个人习惯,因为默认的mysql的管理员名称是root,所以如果能够修改的话,能够防止一些脚本小子对系统的穷举。我们可以直接修改数据库,把root用户改为"admin"
O^.#d mysql> use mysql;
~&T~1xsFJ mysql> update user set user="admin" where user="root";
\m,PA'nd/ mysql> flush privileges;
LLo;\WGZ
Hz~zu{;{J (4) 提高本地安全性
CAJ'zA|o 提高本地安全性,主要是防止mysql对本地文件的存取,比如黑客通过mysql把/etc/passwd获取了,会对系统构成威胁。mysql 对本地文件的存取是通过SQL语句来实现,主要是通过Load DATA LOCAL INFILE来实现,我们能够通过禁用该功能来防止黑客通过SQL 注射等获取系统核心文件。
r$1Qf}J3= 禁用该功能必须在 my.cnf 的[mysqld]部分加上一个参数:
|>Vb9:q9Po set-variable=local-infile=0
ok[i<zl;' 97]E1j] (5) 禁止远程连接mysql
<} .$l 因为我们的mysql只需要本地的php脚本进行连接,所以我们无需开socket进行监听,那么我们完全可以关闭监听的功能。
m*pJBZxd 有两个方法实现:
w(/S?d
* 配置my.cnf文件,在[mysqld]部分添加 skip-networking 参数
AdEMa}u6 * mysqld服务器中参数中添加 --skip-networking 启动参数来使mysql不监听任何TCP/IP连接,增加安全性。如果要进行mysql的管理的话,可以在服务器本地安装一个phpMyadmin来进行管理。
2iOV/=+ -"`=1l (6) 控制数据库访问权限
3mgD(,(^ 对于使用php脚本来进行交互,最好建立一个用户只针对某个库有 update、select、delete、insert、drop table、create table等权限,这样就很好避免了数据库用户名和密码被黑客查看后最小损失。
=&]L00u. 比如下面我们创建一个数据库为db1,同时建立一个用户test1能够访问该数据库。
^ c<Ve'- mysql> create database db1;
2HdC |$_+ mysql> grant select,insert,update,delete,create,drop privileges on db1.* to test1@localhost identified by 'admindb';
/(cPfZZ 以上SQL是创建一个数据库db1,同时增加了一个test1用户,口令是admindb,但是它只能从本地连接mysql,对db1库有select,insert,update,delete,create,drop操作权限。
53D]3 .]u/O`c] (7) 限制一般用户浏览其他用户数据库
ZH8,KY" 如果有多个数据库,每个数据库有一个用户,那么必须限制用户浏览其他数据库内容,可以在启动MySQL服务器时加--skip-show-database 启动参数就能够达到目的。
?}0 ,o. |N2#ItBbW (8) 忘记mysql密码的解决办法
>j/w@Fj 如果不慎忘记了MySQL的root密码,我们可以在启动MySQL服务器时加上参数--skip-grant-tables来跳过授权表的验证 (./safe_mysqld --skip-grant-tables &),这样我们就可以直接登陆MySQL服务器,然后再修改root 用户的口令,重启MySQL就可以用新口令登陆了。
vt8By@]: ]`K2N (9) 数据库文件的安全
vgPCQO([ 我们默认的mysql是安装在/usr/local/mysql目录下的,那么对应的数据库文件就是在/usr/local/mysql/var目录下,那么我们要保证该目录不能让未经授权的用户访问后把数据库打包拷贝走了,所以要限制对该目录的访问。
~ a: 我们修改该目录的所属用户和组是mysql,同时改变访问权限:
Oz95 # chown -R mysql.mysql /usr/local/mysql/var
Pal=F0-Q\ # chmod -R go-rwx /usr/local/mysql/var
&pRREu:[4L %Zi} MPx (10) 删除历史记录
$I=~S[p 执行以上的命令会被shell记录在历史文件里,比如bash会写入用户目录的.bash_history文件,如果这些文件不慎被读,那么数据库的密码就会泄漏。用户登陆数据库后执行的SQL命令也会被MySQL记录在用户目录的.mysql_history文件里。如果数据库用户用SQL语句修改了数据库密码,也会因.mysql_history文件而泄漏。所以我们在shell登陆及备份的时候不要在-p后直接加密码,而是在提示后再输入数据库密码。
N['.BN 另外这两个文件我们也应该不让它记录我们的操作,以防万一。
tA;}h7/Lc~ # rm .bash_history .mysql_history
8=l%5r^cq # ln -s /dev/null .bash_history
kj_c%T
]/ # ln -s /dev/null .mysql_history
,prf;|e? XTyxr (11) 其他
t# i#(H 另外还可以考虑使用chroot等方式来控制mysql的运行目录,更好的控制权限,具体可以参考相关文章。
k:;r2f \dVOwr v+XJ*N[W 4. vsFTPd安全设置
(HVGlw'` X8|, vsFTPd是一款非常著名的ftp daemon程序,目前包括Redhat.com在内很多大公司都在使用,它是一款非常安全的程序,因为它的名字就叫:Very Secure FTP Daemon (非常安全的FTP服务器)。
DVA:Cmh\ vsftpd设置选项比较多,涉及方方面面,我们下面主要是针对安全方面进行设置。
;+%rw 2Z,B 目前我们的需求就是使用系统帐户同时也作为是我们的FTP帐户来进行我们文件的管理,目前假设我只需要一个帐户来更新我的网站,并且我不希望该帐户能够登陆我们的系统,比如我们的网站的目录是在/usr/www下面,那么我们新建一个用户ftp,它的主目录是/usr/www,并且它的shell 是/usr/sbin/nologin,就是没有shell,防止该用户通过ssh等登陆到系统。
r&CiSMS* t0S1QC+ 下面在进行系统详尽的设置,主要就是针对vsftpd的配置文件vsftpd.conf文件的配置。
Cye.gsCT z_HdISy0 (1) 禁止匿名用户访问, 我们不需要什么匿名用户,直接禁止掉:
/xhKd]Q anonymous_enable=NO
1#x0 q:6 Da|z"I
x (2) 允许本地用户登陆,因为我们需要使用ftp用户来对我们网站进行管理:
oU8q o-J1H local_enable=YES
s AkdMo r@V!,k#S (3) 只允许系统中的ftp用户或者某些指定的用户访问ftp,因为系统中帐户众多,不可能让谁都访问。
Psf#c:*_) 打开用户文件列表功能:
kmW4:EA% userlist_enable=YES
Y4-t7UlS; 只允许用户文件列表中的用户访问ftp:
'DR!9De userlist_deny=NO
eFgA 8kY) 用户名文件列表路径:
7dWS userlist_file=/etc/vsftpd.user_list
,bi^P>X
P0@,fd< 然后在/etc下建立文件 vsftpd.user_list 文件,一行一个,把用户ftp加进去,同时也可以加上你允许访问的系统帐户名。
TbU#96"~. 4 KiY6) (4) 禁止某些用户登陆ftp:
(=0.in Z pam_service_name=vsftpd
F5<Hm_\: 指出VSFTPD进行PAM认证时所使用的PAM配置文件名,默认值是vsftpd,默认PAM配置文件是/etc/pam.d/vsftpd。
V0@=^Bls LV Ge]lD /etc/vsftpd.ftpusers
Xvu(vA VSFTPD禁止列在此文件中的用户登录FTP服务器,用户名是一行一个。这个机制是在/etc/pam.d/vsftpd中默认设置的。
tw;}jh 1Mzmg[L8 这个功能和(3)里的功能有点类似,他们俩能结合使用,那样就最好了。
'L'R9&o<X 5!
{D! (5) 把本地用户锁定在自己的主目录,防止转到其他目录,比如把/etc/passwd给下载了:
7.Op< chroot_local_users=NO
<E~'.p, chroot_list_enable=YES
X'srL j. chroot_list_file=/etc/vsftpd.chroot_list
dV_G1' 然后在/etc下建立vsftpd.chroot_list文件,里面把我们要限制的本地帐户加进去,一行一个,我们加上ftp,防止它登陆到系统。
]^E?;1$f? la!~\wpa (6) 隐藏文件真实的所有用户和组信息,防止黑客拿下ftp后查看更多系统用户信息:
dPlV>IM$z hide_ids=YES
T)/eeZ$ FPz9N@M%Q (7) 取消ls -R命令,节省资源,因为使用该命令,在文件列表很多的时候将浪费大量系统资源:
o/E >f_k[ ls_recurse_enable=NO
jcOcWB| 1}x%%RD_ (8) 上传文件的默认权限,设置为022:
HJ"GnZp< local_umask=022
uRvP hkqm 如果要覆盖删除等,还要打开:
';CNGv - write_enable=YES
0mE 0 j Ud?Q%)X (9) ftp的banner信息,为了防止黑客获取更多服务器的信息,设置该项:
^qs $v06 ftpd_banner=banner string
t Q)qCk07 把后面的banner string设为你需要的banner提示信息,为了安全,建议不要暴露关于vsFTPd的任何信息。
_6Sp QW 另外,如果你的信息比较多的话,可以设置为提示信息是读取一个文件中的信息:
B\~}3!j banner_file=/directory/vsftpd_banner_file
oJ^P(] dw X?O[r3< (10) 打开日志功能:
@d'j zs xferlog_enable=YES
H_a[)DT 同时设置日志的目录:
zhQJy?>'m xferlog_file=/var/log/vsftpd.log
7!1S)dup 启用详细的日志记录格式:
3]Ct6 xferlog_enable=YES
(PLUFT ?<!| (11) 如果打开虚用户功能等,那么建议关闭本地用户登陆:
oH@78D0A local_enable=NO
Nn6%9PX_) kiEa<-] w)f#V s vsFTPd还有很多安全设置,毕竟人家的名字就是:Very Secure FTP Daemon,反正它的溢出漏洞什么的是很少的,如果要更安全,建议按照自己的需要设置vsftpd,设置的好,它绝对是最安全的。
:#Wd~~d )=+|i3]U G|Ti4_w
5. SSH安全设置
i-1op> Y &C}*w2]0S SSH是一个基于SSL的安全连接远程管理的服务程序,主要出现就是为了解决telnet、rlogin、rsh等程序在程序交互过程中存在明文传输易被监听的问题而产生的,目前基本上是推荐使用ssh来代替telnet、rlogin、rsh等远程管理服务。
=_CzH(=f# ssh能够直接在windows平台下通过Secure SSH Client等客户端工具进行连接管理,目前最流行的服务器端就是OpenSSH程序,目前最新版本是OpenSSH4.0版,详细可以参考
www.openssh.com网站。
"oyo#-5z OpenSSH在FreeBSD下已经集成安装了,FreeBSD5.3下的OpenSSH版本是3.8.1,建议ports升级到4.0。
wwqEl( Wtnfa{gP% F?0Ykjh3 主要的安全配置文件是/etc/ssh/sshd_config文件,我们编辑该文件。
\fOEqe*5SM vx
=&QavL (1) 使用protocol 2代替protocol 1,SSH2更加安全,可以防止攻击者通过修改携带的版本banner来劫持(hijacking)启动会话进程并降低到protocol 1。注释掉protocol 2,1 改用下面语句代替:
#!=tDc
& protocol 2
VbYdZCC )%TmAaj9d (2) 合理设置最大连接数量, 防止DOS攻击
F ,kZU$ F59 TZI MaxStartups 5:50:10
W9&=xs6 }e1ZbmW (3)关闭X11forwording ,防止会话劫持
NEs:},)o xT8?&Bx X11Forwarding no
iZmcI;?u =pNY
eR_[ (4)建议不使用静态密码,而使用DSA 或RSA KEY,修改如下内容可以关闭使用密码认证:
UKGPtKE< *~`(RV PasswordAuthentication no
h[ ZN+M i8p6Xht (5)可以限制某个组或光是单个用户访问shell
" bG2: PT
~D",k AllowGroups wheel
G@0&8 或者
V`5O{Gg AllowUsers heiyeluren
+@UV?"d )J |6 -C (6) 限制root用户登陆,主要是为了防止暴力破解
TeQV?ZQ#} rv;3~'V PermitRootLogin no
:RYTL'hes x`s>*^ (7) 不允许口令为空的用户登陆
}V>T M{ U$g?!Yl0 PermitEmptyPasswords no
f);FoVa6 MV"=19] (8)使用TCP wrappers来限制一些访问,修改/etc/hosts.allow文件,注释掉"ALL : ALL : allow",增加如下内容:
#yen8SskB XppOU sshd:localhost:allow
ZCw]m#lS sshd:friendlcomputer:allow
NK+o1 sshd:all : deny
KvSG; \vNU,WO #相关命令:
buC{r, #chsh -s /sbin/nologin user