(2) Apache的日志文件
,LZ(^u Apache的日志文件是非常重要的,可以发现apache的运行状况和访问情况,对于判断入侵等有重要帮助。它的默认选项是:
0x71%=4H^x # 错误日志存放目录,默认是存放在apache安装目录的logs下
NjP ]My ErrorLog logs/error_log
:o$@F-$k # 日志记录的级别,级别有debug, info, notice, warn, error, crit等,默认是“warn”级别
t'aSF{% LogLevel warn
"kr,x3
= # 访问日志记录的格式,每一种格式都有不同的内容,根据你的需要进行定制,以获取最多访问信息
w_3xKnMT\ LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined
g ;LVECk LogFormat "%h %l %u %t \"%r\" %>s %b" common
)!a$#"' LogFormat "%{Referer}i -> %U" referer
ETm]o
LogFormat "%{User-agent}i" agent
D$hQyhz' # 使用上面格式的那一种,默认是使用common
bpp* CustomLog logs/access_log common
u~}%1 (#z;(EN0t 文件格式预定义的格式内容:
^#w{/C/n %a 远程用户IP
}4vjKSV %A 本地httpd服务器的ip
G/(*foT8SE %f 传送的文件名
u>|"28y %h 远程主机
4=s9A %m 请求方式
O9*p0%ug %l identd给出的远程名
`p1DaV %p 连接的httpd端口号
:x+ig5 %P 请求的httpd进程
\xeVDKJH+n %t 时间
k/bque %T 服务请求时间
!qw4mN 你可以定制自己的日志格式,然后通过CustomLog logs/access_log common来进行调用。
"l2bx $}4K`Iu 注意,日志文件是由运行Apache的用户进行打开的,要注意该文件的安全,防止被黑客改写或者删除。
5[<F_"x OpqNEo\ (3) Apache服务信息显示控制
N8 M'0i? 在配置文件中有个选项是控制是否显示apache版本信息、主机名称、端口、支持的cgi等信息的:
*%?d\8d ServerSignature On
Cya5*U0= 默认为On,那么将显示所有信息:
3Ta>Ki 我故意访问一个不存在的文件:
http://www.target.com/404.html \k4pK &b 那么就会在给的错误提示中显示如下信息:
|z+9km7, Apache/2.0.53 (Unix) PHP/4.3.11 Server at target.com Port 80
.+vd6Uc5a XNlhu^jh 所有Apache和PHP的信息暴露无遗,这是很不安全的。当然同时还有Off和EMail选项,Off将不显示任何信息,EMail将显示管理员的邮箱地址,建议设为Off或者EMail,这样能够避免泄漏Apache服务器的信息给黑客。
C fSl
54 T<M?PlED (4) 目录浏览
9gR.RwR X 在httpd.conf中可以设置apache能够对一些没有索引文件的网页目录进行目录浏览:
!o<ICHHH u}m.}Mws Options Indexes FollowSymLinks
A;T[[' AllowOverride None
J 8q y1u9B;Fd 这是不合适也不安全的,建议不需要目录浏览:
F"=Hp4-C Yw[{beo Options FollowSymLinks
HL8(lPgS AllowOverride None
5 H *> h~fWE r w\D>}\ (5) 用户主页
{U6"]f% 设置httpd.conf中的:
]?&H^"= UserDir public_html
yLB~P7K 能够使得每个使用系统的用户在自己的主目录下建立 public_html 目录后就能够把自己的网页放进该目录,然后通过:
`oVB!eapl http://www.target.com/~用户名/网页 就能够显示自己的网页,这是不安全的,而且对于我们服务器来讲,这没有必要,所以我们直接关闭该功能:
Rn;VP:H M UserDir disabled
]?#
#))RUS 或者把该内容改名,改成 一个黑客比较不容易猜到的文件名,比如:
`VXZ khm UserDir webserver_public_htmlpath
*/Cj$KY70 也可以只允许部分用户具有该功能:
7t3X`db UserDir enabled user1 user2 user3
^r4|{ iN`6xkY (6) CGI执行目录
0[i}rC9& 如果你的apache要执行一些perl等cgi程序,那么就要设置一下选项:
V Y_f = ScriptAlias /cgi-bin/ "/usr/local/apache/cgi-bin/"
1vsu[n 但是这也给了黑客利用一些不安全的cgi程序来进行破坏,所以如果你不需要cgi的话,建议关闭该选项:
C d|W#.6 #ScriptAlias /cgi-bin/ "/usr/local/apache/cgi-bin/"
yl]UUBcQ e2bLkb3c (7) 控制PHP脚本只能访问指定目录
%ZuLl( 在httpd.conf添加如下内容:
(Xj.iP php_admin_value open_basedir /usr/www
>|(%2Zl 后面的路径是你需要PHP脚本能够访问的目录,如果PHP脚本想要访问其他目录将出项错误提示。
z{' 6f@] '+6<U[ L (8) 目录访问控制 (未完)
-nGwuEngP 这项内容最复杂,同时涉及的东西也比较多,我只能简单说一下,不清楚请参考其他文章。
itHM7d 比如下面的内容:
oR#my ^ 6J"(xT Options FollowSymLinks
qPUA!-' AllowOverride None
yXrd2?Rq@ f,JX" 就是允许访问每一个目录,里面设置的是允许执行的动作,一般包含的动作有:Options、AllowOverride、Order、Allow、Deny。
on_H6Y@B52 Options是只对指定目录及其子目录能够执行的操作,Indexes、Includes、FollowSymLinks、ExecCGI、MultiViews、None、All等操作。
3t*# !^$ AllowOverride是指定目录访问的权限,当然也可以通过 AccessFileName文件指定的 .htaccess 来控制。它的操作有:None、All、Options、FileInfo、AuthConfit、Limit等。
%i3{TL Order、Allow、Deny三个指令必须配合来控制目录访问权限。Order指定检查次序的规则,比如Order Allow, Deny,表示先按Allow检查,如果不匹配再按Deny进行检查。Order Deny, Allow ,表示先按Deny规则检查,如果不满足条件,再按Allow进行检查。
h(|;\ ~ Zd+> 控制目录访问权限的文件
(,U7 R^ 默认在Unix平台下能够使用 .htaccess 来对目录权限进行规则定义,但是这是不安全的,建议关闭,默认的选项:
!pl_Ao~( AccessFileName .htaccess
Rhv%6ekI 建议设成:
C
rfRLsN] #AccessFileName .htaccess
zu C5@jy.x 全部目录权限定义使用httpd.conf中的定义,不使用 .htaccess。
D!/0c]" #EFMgQO (9) 用户访问认证
e z+yP,.# 这个技术非常重要,能够控制一些非法用户访问本内容。假设我们的网站:
http://www.target.com/admin 是我们的后台管理目录,我不允许一些非法用户进行访问,那么我就必须设定对该目录访问是需要验证的。
)6 k1 P 先在httpd.conf中加入要进行访问认证的目录:
F0&O/-w&u N2% :h;tf authtype basic
]$|st^Q authname "Private"
S
QSA%B$< authuserfile /usr/local/apache/bin/admin.dat
WDvV
LU` require user login_user
Pfk{ =y Options Indexes FollowSymlinks MultiViews
N"K\ick6J AllowOverride None
QheDF7'z A'`P2Am 上面我们就设置了我们的 /usr/www/admin目录是必须进行认证才能访问的,接着我们设置访问密码:
&8afl"_~ # /usr/local/apahche/bin/htpasswd -c /usr/local/apache/bin/admin.dat login_name
s_v}=C^ New password: *****
@'Q%Jc( Re-type new password: *****
e lay
=%) Adding password for user login_name
9ClF<5?M 4M7^
[G 那么下次任何用户访问
http://www.target.com/admin目录的时候就需要输入用户名login_name和你设置的密码。
Op90NZI#K );!dg\U uD[^K1Ag]^ 2. PHP安全设置
0H<4+
*`K Z7oaQ\fR PHP本身再老版本有一些问题,比如在 php4.3.10和php5.0.3以前有一些比较严重的bug,所以推荐使用新版。另外,目前闹的轰轰烈烈的SQL Injection也是在PHP上有很多利用方式,所以要保证安全,PHP代码编写是一方面,PHP的配置更是非常关键。
@f%wd2 我们php手手工安装的,php的默认配置文件在 /usr/local/apache2/conf/php.ini,我们最主要就是要配置php.ini中的内容,让我们执行php能够更安全。
)lOji7&e 整个PHP中的安全设置主要是为了防止phpshell和SQL Injection的攻击,一下我们慢慢探讨。我们先使用任何编辑工具打开/etc/local/apache2/conf/php.ini,如果你是采用其他方式安装,配置文件可能不在该目录。
=nw0# ' u
X>PefR (1) 打开php的安全模式
Q~b_dx{m php的安全模式是个非常重要的内嵌的安全机制,能够控制一些php中的函数,比如system(),同时把很多文件操作函数进行了权限控制,也不允许对某些关键文件的文件,比如/etc/passwd,但是默认的php.ini是没有打开安全模式的,我们把它打开:
boIVU`F-! safe_mode = on
d _uFY:
C6CGj8G (2) 用户组安全
w~n kNqm 当safe_mode打开时,safe_mode_gid被关闭,那么php脚本能够对文件进行访问,而且相同组的用户也能够对文件进行访问。
BPqwDjW 建议设置为:
YY\Rua/nG safe_mode_gid = off
I0(8Z]x 如果不进行设置,可能我们无法对我们服务器网站目录下的文件进行操作了,比如我们需要对文件进行操作的时候。
v/x*]c!"` zaBG= (3) 安全模式下执行程序主目录
^ISQ{M#_ 如果安全模式打开了,但是却是要执行某些程序的时候,可以指定要执行程序的主目录:
_Po#ZGm~ safe_mode_exec_dir = /usr/bin
!bieo'c 一般情况下是不需要执行什么程序的,所以推荐不要执行系统程序目录,可以指向一个目录,然后把需要执行的程序拷贝过去,比如:
8| Sba<d safe_mode_exec_dir = /tmp/cmd
ZRUh/<\[ 但是,我更推荐不要执行任何程序,那么就可以指向我们网页目录:
[C2kK *JZ safe_mode_exec_dir = /usr/www
}pt-q[s> AsD1-$ (4) 安全模式下包含文件
$=lJG(2% 如果要在安全模式下包含某些公共文件,那么就修改一下选项:
"`[ $&:~ safe_mode_include_dir = /usr/www/include/
O8iu+}]/6 其实一般php脚本中包含文件都是在程序自己已经写好了,这个可以根据具体需要设置。
XA?WUR[e `k!UjO72 (5) 控制php脚本能访问的目录
(%.</|u 使用open_basedir选项能够控制PHP脚本只能访问指定的目录,这样能够避免PHP脚本访问/etc/passwd等文件,一定程度上限制了phpshell的危害,我们一般可以设置为只能访问网站目录:
We|-5 open_basedir = /usr/www
F-$Kv-f }~V,_Fv (6) 关闭危险函数
Xa>}4j. 如果打开了安全模式,那么函数禁止是可以不需要的,但是我们为了安全还是考虑进去。比如,我们觉得不希望执行包括system()等在那的能够执行命令的php函数,或者能够查看php信息的phpinfo()等函数,那么我们就可以禁止它们:
|fx#KNPf] disable_functions = system,passthru,exec,shell_exec,popen,phpinfo
f7S^yA[[ 如果你要禁止任何文件和目录的操作,那么可以关闭很多文件操作
+H[Q~P8'[ disable_functions = chdir,chroot,dir,getcwd,opendir,readdir,scandir,fopen,unlink,delete,copy,mkdir,rmdir,rename,file,file_get_contents,fputs,fwrite,chgrp,chmod,chown
H8(C>w-' 以上只是列了部分不叫常用的文件处理函数,你也可以把上面执行命令函数和这个函数结合,就能够抵制大部分的phpshell了。
1ZKz3)K S7Qen6lm (7) 关闭PHP版本信息在http头中的泄漏
6OMb`A@/2 我们为了防止黑客获取服务器中php版本的信息,可以关闭该信息斜路在http头中:
FDl,Ey^r/ expose_php = Off
2}59 7Hb 比如黑客在 telnet
www.target.com 80 的时候,那么将无法看到PHP的信息。
H RWZ0 ' juR (8) 关闭注册全局变量
'aNahzb 在PHP中提交的变量,包括使用POST或者GET提交的变量,都将自动注册为全局变量,能够直接访问,这是对服务器非常不安全的,所以我们不能让它注册为全局变量,就把注册全局变量选项关闭:
]S*E register_globals = Off
"i}Z(_7yr 当然,如果这样设置了,那么获取对应变量的时候就要采用合理方式,比如获取GET提交的变量var,那么就要用$_GET['var']来进行获取,这个php程序员要注意。
t
]71 [9w, WJL (9) 打开magic_quotes_gpc来防止SQL注入
jt/l,=9YK SQL注入是非常危险的问题,小则网站后台被入侵,重则整个服务器沦陷,所以一定要小心。php.ini中有一个设置:
#DrZ`Aq magic_quotes_gpc = Off
WT I 'O 这个默认是关闭的,如果它打开后将自动把用户提交对sql的查询进行转换,比如把 ' 转为 \'等,这对防止sql注射有重大作用。所以我们推荐设置为:
s8{-c^G:R magic_quotes_gpc = On
on6<l .0?ss0~ (10) 错误信息控制
>\RDQ%z 一般php在没有连接到数据库或者其他情况下会有提示错误,一般错误信息中会包含php脚本当前的路径信息或者查询的SQL语句等信息,这类信息提供给黑客后,是不安全的,所以一般服务器建议禁止错误提示:
'T6B_9GQ8 display_errors = Off
Feh"!k <6k 如果你却是是要显示错误信息,一定要设置显示错误的级别,比如只显示警告以上的信息:
~>.awu+o| error_reporting = E_WARNING & E_ERROR
xh=FkY&d 当然,我还是建议关闭错误提示。
gD,A9a(3 )`e^F9L (11) 错误日志
-,[~~ 建议在关闭display_errors后能够把错误信息记录下来,便于查找服务器运行的原因:
_!|=AIX log_errors = On
<XU8a:w'T 同时也要设置错误日志存放的目录,建议根apache的日志存在一起:
h5<T.vV error_log = /usr/local/apache2/logs/php_error.log
h 3eGq:!9 注意:给文件必须允许apache用户的和组具有写的权限
Xqc'R5Cw 3. Mysql的安全设置
X
S6]C{ X+/{%P!w 我们把Mysql安装在 /usr/local/mysql目录下,我们必须建立一个用户名为mysql,组为mysql的用户来运行我们的mysql,同时我们把它的配置文件拷贝到 /etc目录下:
Jii?r*"d # cp suport-files/my-medium.cnf /etc/my.cnf
-WQ_[t9l chown root:sys /etc/my.cnf
uPM8GIvZX. chmod 644 /etc/my.cnf
Wdei`u[ iH($rSE 使用用户mysql来启动我们的mysql:
K]*g, s+ # /usr/local/mysql/bin/mysqld_safe -user=mysql &
*Pa2bY3: F+lm [4n (1) 修改root用户的的口令
mjWp8i
缺省安装的mysql是没有密码的,所以我们要修改,以防万一。下面采用三种方式来修改root的口令。
2O}s*C$Xav BDarJY * 用mysqladmin命令来改root用户口令
41P4?"O # mysqladmin -uroot password test
o'9OPoof:. 这样,MySQL数据库root用户的口令就被改成test了。(test只是举例,我们实际使用的口令一定不能使用这种易猜的弱口令)
e);bF>.~ a*pXrp@ * 用set password修改口令:
;9 =}_h)] mysql> set password for root@localhost=password('test');
IwZZewb-a 这时root用户的口令就被改成test了。
#fJ/KYJU D}=/w+ * 直接修改user表的root用户口令
|JirBz mysql> use mysql;
j+z' mysql> update user set password=password('test') where user='root';
AAeQ- nbP mysql> flush privileges;
Dx p> }rFsU\]:q 这样,MySQL数据库root用户的口令也被改成test了。其中最后一句命令flush privileges的意思是强制刷新内存授权表,否则用的还是缓冲中的口令,这时非法用户还可以用root用户及空口令登陆,直到重启MySQL服务器。
i{%z ?,A}E|jZ (2) 删除默认的数据库和用户
kKFuTem_3 我们的数据库是在本地,并且也只需要本地的php脚本对mysql进行读取,所以很多用户不需要。mysql初始化后会自动生成空用户和test库,这会对数据库构成威胁,我们全部删除。
)Tyky%P+iI 我们使用mysql客户端程序连接到本地的mysql服务器后出现如下提示:
bCJ<=X,g`K mysql> drop database test;
~(w=U * mysql> use mysql;
V{7lltu mysql> delete from db;
5n&)q=jk= mysql> delete from user where not(host="localhost" and user="root");
==PQ-Ia mysql> flush privileges;
V{ 4i$' 9Bbm7Gd (3) 改变默认mysql管理员的名称
+ MOe{:/6 这个工作是可以选择的,根据个人习惯,因为默认的mysql的管理员名称是root,所以如果能够修改的话,能够防止一些脚本小子对系统的穷举。我们可以直接修改数据库,把root用户改为"admin"
CuV=C
Ay> mysql> use mysql;
!#cKF6% mysql> update user set user="admin" where user="root";
4OqE.LFu mysql> flush privileges;
a PcGI {9m!UlTtw (4) 提高本地安全性
~@)-qV^~ 提高本地安全性,主要是防止mysql对本地文件的存取,比如黑客通过mysql把/etc/passwd获取了,会对系统构成威胁。mysql 对本地文件的存取是通过SQL语句来实现,主要是通过Load DATA LOCAL INFILE来实现,我们能够通过禁用该功能来防止黑客通过SQL 注射等获取系统核心文件。
Vz=j)[ 禁用该功能必须在 my.cnf 的[mysqld]部分加上一个参数:
\N'hbT= set-variable=local-infile=0
R{2GQB "-~D!{rS (5) 禁止远程连接mysql
5~<a>> 因为我们的mysql只需要本地的php脚本进行连接,所以我们无需开socket进行监听,那么我们完全可以关闭监听的功能。
IPr*pQ{;c 有两个方法实现:
Xr
* 配置my.cnf文件,在[mysqld]部分添加 skip-networking 参数
Z
L6~Eut * mysqld服务器中参数中添加 --skip-networking 启动参数来使mysql不监听任何TCP/IP连接,增加安全性。如果要进行mysql的管理的话,可以在服务器本地安装一个phpMyadmin来进行管理。
:N+K^gI) /
y":/"h (6) 控制数据库访问权限
Vsm%h^]d 对于使用php脚本来进行交互,最好建立一个用户只针对某个库有 update、select、delete、insert、drop table、create table等权限,这样就很好避免了数据库用户名和密码被黑客查看后最小损失。
"63zc1 比如下面我们创建一个数据库为db1,同时建立一个用户test1能够访问该数据库。
)cv0$ mysql> create database db1;
`-9*@_-=M mysql> grant select,insert,update,delete,create,drop privileges on db1.* to test1@localhost identified by 'admindb';
j?Jd@(*y$ 以上SQL是创建一个数据库db1,同时增加了一个test1用户,口令是admindb,但是它只能从本地连接mysql,对db1库有select,insert,update,delete,create,drop操作权限。
(e bBH FrAqTz (7) 限制一般用户浏览其他用户数据库
.MzP}8^ 如果有多个数据库,每个数据库有一个用户,那么必须限制用户浏览其他数据库内容,可以在启动MySQL服务器时加--skip-show-database 启动参数就能够达到目的。
#%}u8\q 0NuL9 (8) 忘记mysql密码的解决办法
HNkZ1+P { 如果不慎忘记了MySQL的root密码,我们可以在启动MySQL服务器时加上参数--skip-grant-tables来跳过授权表的验证 (./safe_mysqld --skip-grant-tables &),这样我们就可以直接登陆MySQL服务器,然后再修改root 用户的口令,重启MySQL就可以用新口令登陆了。
b_K?ocq r(?'Y y (9) 数据库文件的安全
0k]ju 我们默认的mysql是安装在/usr/local/mysql目录下的,那么对应的数据库文件就是在/usr/local/mysql/var目录下,那么我们要保证该目录不能让未经授权的用户访问后把数据库打包拷贝走了,所以要限制对该目录的访问。
hM1&A 我们修改该目录的所属用户和组是mysql,同时改变访问权限:
mZ& \3m= # chown -R mysql.mysql /usr/local/mysql/var
@wAr[.lZ # chmod -R go-rwx /usr/local/mysql/var
%$9)1"T0Y +r#=n7t (10) 删除历史记录
5Xy^I^J 执行以上的命令会被shell记录在历史文件里,比如bash会写入用户目录的.bash_history文件,如果这些文件不慎被读,那么数据库的密码就会泄漏。用户登陆数据库后执行的SQL命令也会被MySQL记录在用户目录的.mysql_history文件里。如果数据库用户用SQL语句修改了数据库密码,也会因.mysql_history文件而泄漏。所以我们在shell登陆及备份的时候不要在-p后直接加密码,而是在提示后再输入数据库密码。
N('S2yfDR 另外这两个文件我们也应该不让它记录我们的操作,以防万一。
)N%1%bg^- # rm .bash_history .mysql_history
FS]+s> # ln -s /dev/null .bash_history
MK!]y8+Z # ln -s /dev/null .mysql_history
Ztpm_P6 c9cphZ(z (11) 其他
{C,1w 另外还可以考虑使用chroot等方式来控制mysql的运行目录,更好的控制权限,具体可以参考相关文章。
]C!Y~ 8g2-8pa{ *Wuctu^9 4. vsFTPd安全设置
m_PrasZ> 9L)&n.t1
vsFTPd是一款非常著名的ftp daemon程序,目前包括Redhat.com在内很多大公司都在使用,它是一款非常安全的程序,因为它的名字就叫:Very Secure FTP Daemon (非常安全的FTP服务器)。
r-\T}e2Gz vsftpd设置选项比较多,涉及方方面面,我们下面主要是针对安全方面进行设置。
#ZYidt 目前我们的需求就是使用系统帐户同时也作为是我们的FTP帐户来进行我们文件的管理,目前假设我只需要一个帐户来更新我的网站,并且我不希望该帐户能够登陆我们的系统,比如我们的网站的目录是在/usr/www下面,那么我们新建一个用户ftp,它的主目录是/usr/www,并且它的shell 是/usr/sbin/nologin,就是没有shell,防止该用户通过ssh等登陆到系统。
dg'CHxU %gne%9nn 下面在进行系统详尽的设置,主要就是针对vsftpd的配置文件vsftpd.conf文件的配置。
E=tx.h4xG~ \3js} (1) 禁止匿名用户访问, 我们不需要什么匿名用户,直接禁止掉:
\4`saM /x anonymous_enable=NO
7}iewtdy, J!TK*\a2 (2) 允许本地用户登陆,因为我们需要使用ftp用户来对我们网站进行管理:
B3g82dm local_enable=YES
9-Nq[i" ,P; a/{U (3) 只允许系统中的ftp用户或者某些指定的用户访问ftp,因为系统中帐户众多,不可能让谁都访问。
[/fwt! 打开用户文件列表功能:
{pQ@0b userlist_enable=YES
u;'<- _ 只允许用户文件列表中的用户访问ftp:
*nUpO] userlist_deny=NO
T$N08aju# 用户名文件列表路径:
_QOOx+%*5 userlist_file=/etc/vsftpd.user_list
Ymk4Cu.s <>5:u 然后在/etc下建立文件 vsftpd.user_list 文件,一行一个,把用户ftp加进去,同时也可以加上你允许访问的系统帐户名。
OV@h$fg l]58P (4) 禁止某些用户登陆ftp:
J9$]]\52s. pam_service_name=vsftpd
~jRk10T(B 指出VSFTPD进行PAM认证时所使用的PAM配置文件名,默认值是vsftpd,默认PAM配置文件是/etc/pam.d/vsftpd。
UV
*tO15i xjn8)C /etc/vsftpd.ftpusers
zN8V~M; VSFTPD禁止列在此文件中的用户登录FTP服务器,用户名是一行一个。这个机制是在/etc/pam.d/vsftpd中默认设置的。
AN:RY/ %Wo :x*|lz[ 这个功能和(3)里的功能有点类似,他们俩能结合使用,那样就最好了。
]rX?n }9+1<mT9a/ (5) 把本地用户锁定在自己的主目录,防止转到其他目录,比如把/etc/passwd给下载了:
dnWt\>6&
2 chroot_local_users=NO
i&s=!` chroot_list_enable=YES
$M3A+6["H chroot_list_file=/etc/vsftpd.chroot_list
)zc8bS 然后在/etc下建立vsftpd.chroot_list文件,里面把我们要限制的本地帐户加进去,一行一个,我们加上ftp,防止它登陆到系统。
GYb2m"a) ph&H