问题,使用传统的模块化方法安装PHP5.1.* + apache 2.2.2 后不能启动, #//
%&k
BCBU b
提示: =Sa~\k+
"Cannot load C:/php/php5apache2.dll into server: The specified module could not be found." 1@@y]s_.a
)vQNiik#
/`}6rXnw9
原因: >Zo-wYG
ng
9NE8F
PHP压缩包里的php5apache2.dll只适用于apache2.0.* T\fudmj&
:l;,m}#@
解决方法: NA\ x<
*0\k
Z,#BJ
下载 这个文件 并解压.共有三个文件. $ hoYkA
s.KOBNCFa
vcredist_x86.exe /cYk+c
php5apache2.dll L\YZT|
K(
httpd.exe.manifest RyE_|]I62u
;AltNGcM
]| z")gOE
好,开始 Hva{A
#
O'fc/cvh='
1.将 php5apache2.dll 覆盖掉你原来PHP目录下的 php5apache2.dll 文件. 5c)wZ
qhnapZJ
2.将 httpd.exe.manifest 文件复制到你的apache安装目录下的bin文件夹下. 'z~KTDX
pj+tjF6Np
3.双击运行vcredist_x86.exe安装.(如果您的系统里已安装了 .NET framework 2.就可以省掉这一步) }-dF+m:
.jCk#@+
完成!去重启你的apache2.2试试吧.