问题,使用传统的模块化方法安装PHP5.1.* + apache 2.2.2 后不能启动, m[y~-n
j}Svb1A
提示: -a_qZ7
"Cannot load C:/php/php5apache2.dll into server: The specified module could not be found." Z;~%!
P]^8Enp
<Tgubv+J
原因: <`Fl Igo
$~:ZzZO
PHP压缩包里的php5apache2.dll只适用于apache2.0.* q7aqbkwz}
R&t2
解决方法: 9=iMP~?xF
Y{e,I-"{
下载 这个文件 并解压.共有三个文件. oq|o"n)~
9.dZA9l@g
vcredist_x86.exe k~<Ozx^AyY
php5apache2.dll ]g9SUFM
httpd.exe.manifest #
{k$Fk
Z-CA9&4Uh
}T}c%p
好,开始 +fozE?
GBg
1.将 php5apache2.dll 覆盖掉你原来PHP目录下的 php5apache2.dll 文件. &,p6lbP
l8+1{6xP
2.将 httpd.exe.manifest 文件复制到你的apache安装目录下的bin文件夹下. R$}Hv
x%$6l
3.双击运行vcredist_x86.exe安装.(如果您的系统里已安装了 .NET framework 2.就可以省掉这一步) ;dZZOocV1
ho^c#>81
完成!去重启你的apache2.2试试吧.